Let’s Encrypt Warns Some Android Users of Compatibility Issues

Let’s Encrypt has warned users whose devices are running older versions of Android that they may start getting errors next year when visiting websites secured by its certificates.

read more

Read more: Let’s Encrypt Warns Some Android Users of Compatibility Issues

Story added 9. November 2020, content source with full text you can find at link above.